Wednesday, May 30, 2012

HOWTO: Give Network Manager Sufficient Privileges

Nm-applet is easily one of the most flexible network connection tools available under modern Linux distributions today. Because of this it is my network manager of choice. The only issue is that under a good deal of modern window managers (such as E17) nm-applet doesn't let your normal user connect to new networks without a bit of additional configuration.

The following is how to get around the message:

Failed to add new connection: (32) Insufficient privileges.

From the 0.9.x revision of the network manager.

It is a fairly simple fix that simply involves creating a configuration file. Crack open your terminal emulator of choice and run:

sudo nano /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla

For the contents of this file simply paste this and then save+close the file.

Note if your user will need to be part of the netdev group for that code to function (if you don't have a netdev group, any group your user is a part of will work). To check the groups your current user is in simply run groups myusername in terminal (replace myusername with the name of your user clearly).

~Jeff Hoogland

A Bodhi Linux 2.0.0 Beginning

The Bodhi team and I are happy to announce the first pre-release (Read: Not suitable for daily usage machines) of our next major release Bodhi Linux 2.0.0! This release is considered alpha quality and is intended to allow our community to help test this release before it becomes our "stable" version.

The goal of a new major release is not to introduce ground breaking new features. The goal of a major Bodhi release is to allow our distro to transition to the next major Ubuntu LTS as a distro base. That is right folks - these ISO images are built on top of the recently released Ubuntu 12.04 (where is all previous Bodhi versions had been based on Ubuntu 10.04). The most noteworthy thing this release introduces is native support for 64bit. From this point forward all Bodhi releases will come in x86 and 64bit flavors.

Without further wait you can find these discs for download via source forge here.

Things to note with these CD images:

Not everything is going to work - we know this and so should you. The important thing is that when you find something that doesn't work let us know so we can fix it!  The best solution for discussing issues you find is our user forums (not the comments section on this post).

I had a minor brain fart when building the latest set of packages for this image - which means when you select Bodhi Linux->About from the main menu, the version number still appears as "1.4.0", this numbering issue will be resolved within the next week via package manager updates.

The download size is large. Yep - there is nothing wrong with your eyes, those ISO images are kinda fat compared to previous Bodhi releases. This is because I have yet to start manually stripping out packages from the disc that aren't needed. That will be happening between now and the stable release (if you'd like to help with this, please feel free to post lists of pre-installed packages you notice that aren't needed).

The installer slides on the 32bit image have a permissions issue that prevents them from being displayed by the installer by default.

The network manager is not auto launching for the live user - it can be launched manually.

Network manager needs to be run with sudo to add connections - for a fix to this see here.

I will update this list with known issues as they are found/reported.

Thanks for reading and helping us test! Lets make sure this next release is as stable (and awesome) as possible.

~Jeff Hoogland

Monday, May 14, 2012

HOWTO: Diablo 3 on Linux

Like many nerds around the world this evening I am prepping for what, odds are, will be the first of many all-nighters involving Blizzard's soon-to-be-released Diablo III (which releases tonight at midnight!). If you have been by my blog before then odds are you will know that I prefer to do as much of my gaming as possible on my operating system of choice: Linux. Something else you may or may not know is that I am also a large fan of the company Code Weavers that produces the commercial Wine software Crossover.

Want to know the reason I am such a fan of Crossover? A few weekends ago I spent about 6 hours trying to get Wine sources to compile with various patches to make the Diablo 3 open beta work on Linux. The result? I ended up hanging my head in defeat and just playing on my OSx86 system so I didn't miss the weekend event. At that point Diablo 3 didn't work OOTB on default Wine builds or Crossover.

This morning I dropped by #crossover on FreeNode to check in with the Crossover folks to see what their plans were for the Diablo 3 release due out tonight - were us Linux folks going to have to wait?


The Diablo 3 release is something they had been very aware of and had been testing rigorously in-house. I was informed they had internal builds of Crossover where Diablo 3 was functional enough to play this very day. In fact within three hours of my speaking with them they had an "unsupported build" release that was functional with the Diablo 3 installer (note: if you are not a current Crossover customer that above link will not work for you).

I promptly installed the update and was on my merry way:

As of now if you are using Crossover 11.1 or newer Diablo 3 is now officially supported,

Now - if you are not interested in supporting Crossover - you can attempt to succeed where I failed and compile Wine with some of the patches listed on the Diablo 3 Beta AppDB page. Odds are if you wait for the next Wine developmental release or two, Diablo 3 will just start working by default - the Crossover folks are one of the lead contributors to the Wine project and most of their code improvements go upstream.

Trouble Shooting Tips:
If you are having issues getting it to run via the latest Wine builds it might be worth your while to use winetricks to install the "vcrun2008" package.

If your login attempt is hanging at the "authenticating credentials" step, exit Diablo, open a terminal and run:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope

~Jeff Hoogland

Thursday, May 3, 2012

Getting Back into the Swing of Things

Howdy All,

Just wanted to drop a quick note here saying I do still plan to maintain my lovely blog. Last month my school schedule got the best of me and I only managed to eek out a single post that was mostly related to the Diablo 3 Open Beta weekend.

The semester is out in 6 days though - so expect plenty of yummy tech goodness (including the first news of Bodhi 2.0.0!) coming this month.

~Jeff Hoogland