Friday, June 8, 2012

Filling out my FAFSA on FOSS

I want to remind every out there of something:

Never doubt that your voice matters.

Over a year ago I wrote a post complaining that you where unable to complete the "free application for federal student aide" from an FOSS operating system without first tricking the government's website into thinking you are running Windows.

It was time for me to renew my application (it is something you update every year in the US) and I had my user agent changer all ready to go, but before I simply admitted defeat again I first tried with my normal browser settings. Lo and behold was I surprised! While I was still warned that I was using an "unsupported" browser - the FAFSA website no longer prevented me from filling out the application from said browser.

This is fantastic to say the least - it is a step in the right direction: towards a open internet where the platform you are accessing it from doesn't matter. I would like to say thanks to everyone out there who read my post last year and took the time to contact the FAFSA folks to let them know how stupid their policy was - because apparently they listened!

~Jeff Hoogland


  1. I don't remember this restriction being in place when I started my degree program in 2005. I also helped my son fill one out in 2011. Both times in Linux with Firefox.

  2. You can use User Agent Switcher for Firefox to
    get around FAFSA's "supported browser" quirks.

    Chrome supports User Agent spoofing from its command line; plus you can have fun finding the right user agent string.

  3. I remember your post last year, Jeff. I had been annoyed by the same thing. Perhaps enough complaints were registered.

    Well, any victory big or small should be celebrated. So: yay!

  4. I remembered your post as well and had identical experiences. It's doubley frustrating when you can use 'user agent switcher' and know that claims of incompatibility are just ignorance.