Friday, March 11, 2011

Bodhi Linux Final Release Candidate Goes Live

The Bodhi Linux team and I are proud to announce the release of our third and final release candidate. This release includes several important bug fixes including several that increase boot time. For a full change log please see the forum post here.

The first thing you will notice is that we now have a new background image for the LiveCD menu and your grub menu:

Bodhi pride's itself on being minimalistic so it doesn't come with much in the way of default applications. We also highly value user input and after conducting a poll we came to the conclusion that Fiefox 4.0 was no longer the best default browser. After having almost a three way split between Firefox 3.6, Firefox 4.0, and Chromium for favorite browser, the team and I made the choice of going with something that was light and wouldn't take up much disc space on the default install.

The winner ended up being Midori. Midori is a fast, GTK based, webkit browser that has an install foot print of only a few megabytes. After working with the Midori developers the browser now also supports the AptURL protocol necessary for it to function with our online software center.

Speaking of default software - you will notice one new tool in the default install of Bodhi. The light weight graphical text editor Leafpad is now packaged by default. Don't worry, this is the last added application you will see in Bodhi.

After installing you will notice that our login screen no longer has excessively large "login" text on it:

After logging in you will notice we have a new theme in our default selection - Brown on Bodhi:

If you are using Bodhi on a tablet computer you should be happy to know we are now using the developmental (but stable and sleek) ELFE launcher by default in our tablet profile:

ELFE video preview:

The team at Bodhi has also been steadily growing. We have four translators working on our team now and you will find our quick start guide (default local home page on the disc) is now available in five languages.

This is our last release candidate before our "stable" release at the end of this month. We are fairly certain most of the kinks are worked out at this point, but if you do find any bugs please be sure to let us know about them!

You can get Bodhi in 32bit flavor via direct download here or torrent download here.

~Jeff Hoogland


  1. Congrats! Did you guys add in ALSA to the base disc? That's pretty much the only other program I think is needed. Also, FF 4.0 has been great. I think it's not a good choice to drop it for a no-name browser.

  2. Alsa utils are now included in the disc by default.

    You can easily install firefox 4.0 (rc1 now!) via one command in terminal or a couple clicks on our software site.

  3. I would just really like to have a 64bit iso...

  4. I've been running Bodhi for a month now. Posting lots of dumb questions over at LinuxQuestions. ;)

    I did the apt-get upgrade, so I should be good to go, and I still am running FF 4.0. Nice to see alsa got added to the iso, as well.

  5. Jeff, can you make it so, every time you change your Bodhi, so we can either upgrade or downgrade it to the current one? You see, no need to worry so much about Dedoimedo or anyone else criticizing. Even your 1st attempt (0.1.5) is working well!

    Your Bodhi is an operating system, not a distro, and that's the point some don't realize.

    Keep up the good work!

  6. "de do I me do" is pointless "we do what I do" makes more sense. Bodhi is clearly minimalistic from the start. I really like it. Thanks for sharing.

  7. if I make a /home partition, would a direct upgrade (overwrite install) from one version to another work effectively without messing with anything too majorly?

  8. I have just been doing apt-get upgrades, and everything's been fine. I've been told NOT to do a dist-upgrade, as that screws up the repos from Ubuntu.
    If you're doing a new install with a new disk, I think you should backup up your home drive first on a USB or other hard drive. I would do this even with very stable and reliable distros like Red Hat, if I was using it.

  9. Is it possible to install the OS on a mem stick?

  10. I've never heard of Bodhi before, but it looks kinda cool.

  11. I absolutely LOVE Bodhi Linux. It looks amazing and there's so much you can do with it. Great job. I was wondering if there is a 64-bit version available. I would really like to run Bodhi as my main operating system, but I'd like a 64-bit version instead of 32. Any plans to release a 64-bit version or is there a 64-bit currently available?

  12. 64bit support is a ways off, but it is coming -

    Slow and steady...

  13. I'm assuming it will be possible to install ELFE on someting like the Pandigital Novel and other type tablets. If Jeff will have some "how to guides" I'd love to try and show to others.

  14. Hello!

    Is the root pass the same as I created for my account? I was not asked to create the root password during bodhi installation, now I would like to install graphics card driver and it won't let me because I am not logged in as root,does Bodhi Linux has predefined root login?
    Thank you for your help!

  15. Bodhi uses sudo instead of root. Login as root by running:

    sudo su

    and entering your normal root password.

  16. me he descargado las 3 ultimas versiones y cada vez estoy mas contento, excelente trabajo!

  17. I tried Bodhi after reading the Dedoimedo review just to see how crappy it really was. Guess what..its not crappy at all. I quite like it actually!! Very nice to actually have a bare system and having a choice on what you want installed. The use of Enlightenment is also refreshing. I wonder how many people tried out Bodhi after reading that review, and how many people where pleasantly suprised (such as myself) at how good this OS really is!! keep up the good work!

  18. Hi there, congrats for your work!
    E17-based distros are just too few, and this one is really worth a try, even at its early stage ;-)
    However, Ubuntu-based distros are just too numerous :-( Wy not consider using a Debian base instead?
    I don't know if it works on a physical machine, but Bodhi didn't automount the VBoxGuestAdditions.iso disc image in VirtualBox. Any idea why, or functionality not implemented yet?
    I will carefully follow the evolution of your project, and hope it won't drop E17 (like MoonOS did), or stop updating (like OzOS and OpenGEU did)...

  19. Try add : libjpeg-turbo for ubuntu 10.04
    and 200 lines kernel patch

    Much faster on firefox 3.6.15. I really think that we should use stable firefox for several reasons:
    1. Most linux users use it and feel at home.
    2. Most Addons work.
    3. the same reason for choosing 10.04.

  20. Hi Jeff, I have found a good article about bodhi linux on Ghacks...

  21. Hi. I have downloaded this RC for a try in a very old PC (an AMD K6-2), but I got that known message error about "cmov". Well, I got confused about the specs that says "System Requirements Minimum are a 300mhz i386 Processor"... shouldn't be corrected to a "i686 processor"? It seens that this RC is compiled for that. Am I wrog? Tnx.

  22. Jeff,

    Did this release candidate happen to have any fixes for the older hardware boot problem? I am one that had the 0.1.5 boot problem about a week ago.

    I did see the recommendation of the forum post "Pentium 1 - Wrong Kernel" to replace the kernel. I have enough spare disk space on my primary desktop to load Bodhi and do what is recommended. I wouldn't be put off in re-compiling the kernel as I did that a couple of times back in the days of Linux 1.x. The one thing I would like to know is if you re-compile and do any tweaks to Makefile?

    If I have success, I will gladly contribute back my work to the Bodhi project.

  23. I did not get around to recompiling the kernel for the older hardware no.


  24. Awesome! I've installed Bodhi on Netbooks, Laptops, and use it as my main desktop OS. Love the speed and versatility, keep up the great work!

  25. I was very excited about installing bodhi linux on my 512MB Ram, AMD K6-2 compaq 7470 when I received the error about CMOV. In fact, I am quite certain that Bodhi will not install on a plethora of older AMD systems (AMD K5, K6, K6-2, K6-3), some of which are quite over the minimum 300Mhz as advertised on the Bodhi site. The K6-3 even competed directly with pentium IIIs. Is there any way to "easily" get around this, other than the obvious (switching to another distro). I am not a linux guru and lack the expertise to compile older kernels, etc.

    Linus's comments on CMOV:

    I especially liked this one:
    "CMOV is a piece of CRAP for most things, exactly because it serializes
    three streams of data: the two inputs, and the conditional."


  26. Linux doesn't work on a variety of hardware if you don't have the right kernel drivers. You would need to build a kernel with this older support to boot Bodhi on this hardware. Ubuntu tries to keep it's kernel as generic as possible, but it is impossible to support all hardware no matter what you do.